CarForum.net - Car Forums, Automotive News and Community
Home Gallery Register Calendar Members List

Go Back   CarForum.net - Car Forums, Automotive News and Community > CarForum.net > CarForum.net Technical Issues

Reply
LinkBack Thread Tools
Unread 07-03-2014, 12:20 AM   #1
New Member
 
Join Date: Jul 2014
Posts: 2
Rep: 10 PennyPontiac is on a distinguished road
Default Gr Am 2004 3.4 V6 poor acceleration

My 2004 Gr Am 3.4 V6 has poor acceleration 25 mph -50 mph have changed Oxy sensor, plugs. wires, catalytic convertor. Service engine light comes on but scan shows oxy sensor failed changed 3 ..could this be a problem with intake manifold has 130,000 miles

PennyPontiac is offline  
Reply With Quote
Unread 07-03-2014, 12:22 AM   #2
Veteran Member
 
Mr Car Guy's Avatar
 
Join Date: Mar 2008
Location: Surrey, BC, Canada
Posts: 2,052
Rep: 186 Mr Car Guy has a spectacular aura aboutMr Car Guy has a spectacular aura about
Default

What is the code, there is no " oxygen sensor failed" code.
__________________
2003 GMC Envoy 5.3

Mr Car Guy is offline Mr Car Guy's Gallery  
Reply With Quote
Unread 07-03-2014, 07:33 AM   #3
New Member
 
Join Date: Jul 2014
Posts: 2
Rep: 10 PennyPontiac is on a distinguished road
Default

Thanks, took to mechanic and the scan said to replace the Oxygen sensor which we did 3 times ( warranty on last 2) .Also replaced plugs and plug wires and Catalytic convertor, he thought it might be the intake manifold ? but it still has poor acceleration and power, idles and starts fine and less problems when cool. We are hesitant to spend a bunch more. on this 2004 Gr Am 3.4 litre

PennyPontiac is offline  
Reply With Quote
Unread 07-03-2014, 01:59 PM   #4
Senior Member
 
M_Metzger1114's Avatar
 
Join Date: Jul 2011
Location: Cloverdale, IN
Posts: 428
Rep: 14 M_Metzger1114 is on a distinguished road
Default

The scan won't tell you to replace your o2 sensor. Find out from your mechanic or go to AutoZone and ask what the code is. It should be a p followed by 4 numbers.
__________________
Saphia - 1999 Saturn Sc1 190k ++ 1997 Saturn sl2 223k ++ 1994 Saturn Sl mileage-? ++ 1995 Saturn SW1 236k ++ 1995 Ford Taurus SE 3.0 v6 97k ++ 1989 Ford Bronco 5.8l 351 v8 mileage-?

M_Metzger1114 is offline  
Reply With Quote
Unread 07-04-2014, 12:05 AM   #5
Community Director
 
Mike's Avatar
 
Join Date: Jun 2008
Location: Minneapolis, MN
Posts: 7,602
Rep: 153 Mike has a spectacular aura aboutMike has a spectacular aura about
Default

Also, fire your mechanic.

If there's a fault coming from that oxygen sensor any mechanic worth his salt should check to see if the if the sensor is the problem or the symptom. Sounds like yours is the symptom, which means the sensor is doing its job.
__________________
"He shouted: 'You've won! Didn't you know?' I didn't, and it's about the nicest thing I've ever been told" -Bruce McLaren, 1968 Belgian Grand Prix
Read the rules! | DO NOT REPLY TO SPAM
Daily Driver: 2006 Mazda 3 S sedan - 2.3L I4, 5 speed manual - 78k miles
Girlfriend's Car: 2013 Chevy Volt - 30k miles
Bikes: 1979 Yamaha XS 750


Mike is offline Mike's Gallery  
Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 03:10 AM.

Shogun Interactive Development Copyright 2015 Shogun Interactive Development. All rights reserved.