CarForum.net - Car Forums, Automotive News and Community
Home Gallery Register Calendar Members List

Go Back   CarForum.net - Car Forums, Automotive News and Community > General Car Discussion > General Automotive Discussion

Reply
LinkBack Thread Tools
Unread 06-02-2011, 09:31 AM   #1
Hammond Hand Luggage
 
cluffenstein's Avatar
 
Join Date: Jan 2007
Location: Chicago IL
Posts: 2,704
Rep: 61 cluffenstein will become famous soon enough
Default Expedition Randomly stalls

I've been chasing demons in this stupid truck since I moved in here.

Currently has two codes. Bank 1 and 2 lean. I've replaced the air filter (black) and MAF sensor, light is still on, and no one will clear the codes.

The truck originally started randomly running really rough then stalling. I unplugged the MAF and it tried to stall but didn't. I replaced the MAF, Still tries to stall but doesn't. Yesterday it stalled with the battery light on.

It also has an oil leak somewhere, and a very large hissing sound (can be heard in the truck)

Autozombie said it could still be O2 sensor, or fuel injectors.

She constantly runs it to empty so I'm putting my money on fuel filter (this is an 11 year old truck).
__________________
Quote:
Originally Posted by TestEcull
He may have ruined his cylinder walls and compression wings.
Quote:
Originally Posted by wierdo124
Yeah. Should hold up fine, long as you don't drive like a primate.

cluffenstein is offline cluffenstein's Gallery  
Reply With Quote
Unread 06-02-2011, 04:51 PM   #2
Community Director
 
Mike's Avatar
 
Join Date: Jun 2008
Location: Minneapolis, MN
Posts: 7,602
Rep: 153 Mike has a spectacular aura aboutMike has a spectacular aura about
Default

Hissing means you've got a vacuum leak somewhere. I'd bet that's why it's stalling.
__________________
"He shouted: 'You've won! Didn't you know?' I didn't, and it's about the nicest thing I've ever been told" -Bruce McLaren, 1968 Belgian Grand Prix
Read the rules! | DO NOT REPLY TO SPAM
2009 Pontiac G8 GT - 6.0L, 6AT - 95k miles | 1994 Chevy Blazer K5 - 350, 5MT - 140k miles | 2006 Mazda 3 S sedan - 2.3L, 5MT - 130k miles
Wife's Car: 2013 Chevy Volt - 70k miles
Bikes: 1979 Yamaha XS 750 | 1985 Honda Sabre 700


Mike is offline Mike's Gallery  
Reply With Quote
Unread 06-02-2011, 09:50 PM   #3
Spah sappin' mah susp!
 
Kenny McCormick's Avatar
 
Join Date: Jan 2009
Location: Earth...I think
Posts: 3,271
Rep: 96 Kenny McCormick will become famous soon enough
Default

Hissing...stalling...rough running...bank 1 lean...bank 2 lean...there's a hole in the vacuum lines somewhere. Or perhaps the intake gasket is leaking.
__________________
Tired Iron ain't got no time to wear out...

My rigs:

1985 Ford F150 | 4x2 | 300ci OHV inline six | 4-speed OD manual | 310K | No power brakes | Running 100% - It hasn't driven this good in 15 years!

1984 Ford F150 | 4x2 | 300ci six | granny four | 3.55 rear end | 210K | Brakes shot. Rear drums are doing most of the work. Not fit to drive due to that.
1997 Ford Explorer XLT | 4.0L Vulcan V6 | 5-speed automatic | shift-on-the-fly 4WD | 210,000 miles | Running 95% - Needs brakes on all four corners + bald tires
1989 Ford F150 | 300cid six...again | 5-speed | 4x4 | 160K | Needs brakes done as well. Oi!

Kenny McCormick is offline  
Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 12:21 PM.

Shogun Interactive Development Copyright 2015 Shogun Interactive Development. All rights reserved.