CarForum.net - Car Forums, Automotive News and Community
Home Gallery Register Calendar Members List

Go Back   CarForum.net - Car Forums, Automotive News and Community > General Car Discussion > General Automotive Discussion

Reply
LinkBack Thread Tools
Unread 06-25-2007, 06:49 AM   #1
New Member
 
Join Date: Jun 2007
Posts: 1
Rep: 10 belasuz is on a distinguished road
Default issue - anwar & azam khan (a.k.a. kahn) auctions

have a '98 Saturn SC1. Everything has been running fine since I bought it in 2002, until this morning when I got out of work. When i first started my car, I was hearing a moderately loud squeak (or possibly a rattle). When I put my car in gear and started moving, The "check battery" light came on and the steering wheel would hardly move. I turn the car off, and took out the key, yet I heard something running under the hood, like a loud fan of some sort. I restarted it, and shut it off, and the fan-like sound vanished. I started to make my why home, and the car nearly overhearted. I had to pull off the road to let it cool. I checked all the fluids. The oil level is fine, coolant, power steering etc. is all fine. I got home, and tried to charge the battery using another car. Still I have these issues. Any idea what is going on here?

Bela

belasuz is offline  
Reply With Quote
Unread 06-25-2007, 05:28 PM   #2
Senior Member
 
Dman's Avatar
 
Join Date: May 2007
Posts: 235
Rep: 20 Dman is on a distinguished road
Default

The fan noise is the radiator fan, most cars have a sensor that turns the fan on after you shut the car off if it is overheating to cool the radiator off. You might need to flush out your cooling system and put new coolant in it. Also a temperature sensor may be malfunctioning. If the battery is dead you need to replace it, your altenator may not be working anymore as well, if thats the case you will run into electrical problems in addition to your battery not being charged.
__________________
2010 Altima 2.5 SL

Dman is offline Dman's Gallery  
Reply With Quote
Unread 06-25-2007, 08:44 PM   #3
Senior Member
 
Join Date: Sep 2006
Location: Georgia
Posts: 146
Rep: 20 CavySleeper is on a distinguished road
Default

Quote:
Originally Posted by belasuz View Post
have a '98 Saturn SC1. Everything has been running fine since I bought it in 2002, until this morning when I got out of work. When i first started my car, I was hearing a moderately loud squeak (or possibly a rattle). When I put my car in gear and started moving, The "check battery" light came on and the steering wheel would hardly move. I turn the car off, and took out the key, yet I heard something running under the hood, like a loud fan of some sort. I restarted it, and shut it off, and the fan-like sound vanished. I started to make my why home, and the car nearly overhearted. I had to pull off the road to let it cool. I checked all the fluids. The oil level is fine, coolant, power steering etc. is all fine. I got home, and tried to charge the battery using another car. Still I have these issues. Any idea what is going on here?

Bela
sounds like your serpentine belt broke. your bat. light came on because your alternator wasn't being driven, it was hard to steer because the power steering pump wasn't being driven, and the car almost overheated because the water pump wasn't being driven. did you check to make sure your belt was still there?
__________________
03' Dodge Stratus 2.4L DOHC 150HP, 205/55/16 on 6 spoke painted rims, tinted windows, Infinity sound, upgraded Platinum Champion plugs, 4 speed auto, 2" exhaust.

Top Speed achieved so far: 145
0-70: 9 sec.


"I still wish I had my Cavy!" - Me

CavySleeper is offline  
Reply With Quote
Unread 06-28-2007, 09:37 PM   #4
QUATTRO
 
Join Date: Jul 2006
Location: Potsdam, NY
Posts: 492
Rep: 38 apavlov13 is on a distinguished road
Default

Exactly my thoughts. Definately a broken belt. The fan turned on because the engine was hot. Sound like something like a tensioner or accesoory might have seized, or it was just a belt failure. Before you put a new belt in make sure all pulleys (except the main crank pulley) turn freely. Some accessories like water and power steering pump may have some resistance, which is normal.
__________________
1986 VW Jetta Coupe Diesel - SLOW
1987 Audi 4000 V8 quattro - FAST

apavlov13 is offline apavlov13's Gallery  
Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 12:22 PM.

Shogun Interactive Development Copyright 2015 Shogun Interactive Development. All rights reserved.