CarForum.net - Car Forums, Automotive News and Community
Home Gallery Register Calendar Members List

Go Back   CarForum.net - Car Forums, Automotive News and Community > General Car Discussion > General Automotive Discussion

Reply
LinkBack Thread Tools
Unread 08-12-2014, 06:22 PM   #1
New Member
 
Join Date: Aug 2014
Posts: 2
Rep: 10 unsaint32 is on a distinguished road
Default Mazda3 2004 A/C not working

I lost cold air in my 2004 Mazda3 S HB. I had cold air when I bought this car 2 months ago. Before I lost cold air completely, I had cold air at certain vent inside the car and not other vents.

The clutch engages & does NOT disengage. When I unplug the A/C relay, then it disengages. But the A/C relay is good because I plug the relay into the horn socket and the horn works.

Also, I bought a can of A/C Pro and plugged into the LP port (after A/C turned on and fan full speed), but the pressure gauge reads zero. If the freon is all gone, should the clutch not engage at all?

unsaint32 is offline  
Reply With Quote
Unread 08-12-2014, 07:20 PM   #2
Community Director
 
Mike's Avatar
 
Join Date: Jun 2008
Location: Minneapolis, MN
Posts: 7,602
Rep: 153 Mike has a spectacular aura aboutMike has a spectacular aura about
Default

if you've got no freon you've obviously got a leak somewhere. Find the leak before refilling.
__________________
"He shouted: 'You've won! Didn't you know?' I didn't, and it's about the nicest thing I've ever been told" -Bruce McLaren, 1968 Belgian Grand Prix
Read the rules! | DO NOT REPLY TO SPAM
Daily Driver: 2006 Mazda 3 S sedan - 2.3L I4, 5 speed manual - 78k miles
Girlfriend's Car: 2013 Chevy Volt - 30k miles
Bikes: 1979 Yamaha XS 750


Mike is offline Mike's Gallery  
Reply With Quote
Unread 08-12-2014, 09:51 PM   #3
New Member
 
Join Date: Aug 2014
Posts: 2
Rep: 10 unsaint32 is on a distinguished road
Default

Quote:
Originally Posted by Mike View Post
if you've got no freon you've obviously got a leak somewhere. Find the leak before refilling.
I thought if i had no freon, the ac clutch would not engage?

unsaint32 is offline  
Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 06:43 PM.

Shogun Interactive Development Copyright 2015 Shogun Interactive Development. All rights reserved.