CarForum.net - Car Forums, Automotive News and Community
Home Gallery Register Calendar Members List

Go Back   CarForum.net - Car Forums, Automotive News and Community > General Car Discussion > General Automotive Discussion

Reply
LinkBack Thread Tools
Unread 02-19-2015, 01:40 PM   #1
New Member
 
Join Date: Feb 2015
Posts: 2
Rep: 10 CharleneandPiper is on a distinguished road
Default Can someone help me with Toyota Avalon problem.

My 97 Toyota Avalon just started acting crazy. You have to hit the break for it to change gears and the gauges to work. Now it smells like burning wire. I'm afraid to drive it but it's the only car I have.

CharleneandPiper is offline  
Reply With Quote
Unread 02-19-2015, 07:17 PM   #2
New Member
 
Join Date: Feb 2015
Posts: 2
Rep: 10 CharleneandPiper is on a distinguished road
Default

???

CharleneandPiper is offline  
Reply With Quote
Unread 02-21-2015, 12:25 PM   #3
Community Director
 
Mike's Avatar
 
Join Date: Jun 2008
Location: Minneapolis, MN
Posts: 7,602
Rep: 153 Mike has a spectacular aura aboutMike has a spectacular aura about
Default

you're gonna have to explain a little better.
__________________
"He shouted: 'You've won! Didn't you know?' I didn't, and it's about the nicest thing I've ever been told" -Bruce McLaren, 1968 Belgian Grand Prix
Read the rules! | DO NOT REPLY TO SPAM
2009 Pontiac G8 GT - 6.0L, 6AT - 95k miles | 1994 Chevy Blazer K5 - 350, 5MT - 140k miles | 2006 Mazda 3 S sedan - 2.3L, 5MT - 130k miles
Wife's Car: 2013 Chevy Volt - 70k miles
Bikes: 1979 Yamaha XS 750 | 1985 Honda Sabre 700


Mike is offline Mike's Gallery  
Reply With Quote
Unread 02-28-2015, 02:38 PM   #4
New Member
 
Join Date: Feb 2015
Location: Zagreb
Posts: 1
Rep: 10 automart is on a distinguished road
Default

Quote:
Originally Posted by CharleneandPiper View Post
My 97 Toyota Avalon just started acting crazy. You have to hit the break for it to change gears and the gauges to work. Now it smells like burning wire. I'm afraid to drive it but it's the only car I have.
You will have to check the wiring first as there is probably loose or corroded earth (minus pole) connection.

automart is offline  
Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 06:03 PM.

Shogun Interactive Development Copyright 2015 Shogun Interactive Development. All rights reserved.