CarForum.net - Car Forums, Automotive News and Community
Home Gallery Register Calendar Members List

Go Back   CarForum.net - Car Forums, Automotive News and Community > General Car Discussion > General Automotive Discussion

Reply
LinkBack Thread Tools
Unread 05-14-2009, 06:00 AM   #1
New Member
 
Join Date: May 2009
Posts: 2
Rep: 10 flyboy is on a distinguished road
Default Cruise control switch

I wonder if anyone can help? My Vectra Automatic 2.2 2003 has a problem with the cruise control switch. sometimes it works and other times it lights but will not stay on. It's starting to get me down any advice? could it be a relay? any help will be appreciated.

flyboy is offline  
Reply With Quote
Unread 05-14-2009, 07:27 PM   #2
Retired Director
 
Gandalf's Avatar
 
Join Date: Aug 2006
Location: Indiana, USA
Posts: 1,489
Rep: 36 Gandalf is on a distinguished road
Default

Cruise control is a vacuum-based system...you might want to check it for leaks before anything else.
__________________
Vehicles: 1993 240SX
1990 Katana 750

Gandalf is offline  
Reply With Quote
Unread 05-15-2009, 12:20 AM   #3
Veteran Member
 
Mr Car Guy's Avatar
 
Join Date: Mar 2008
Location: Surrey, BC, Canada
Posts: 2,052
Rep: 186 Mr Car Guy has a spectacular aura aboutMr Car Guy has a spectacular aura about
Default

Sorry I don't know your car, but a few general things to check.

The brake pedal switch turns off your cruise if it's depressed. If the switch is out of adjustment or the pedal is not returning completely it won't stay on, or will shut off occasionally.

Check that your tail lights & brake lights work as they should. A bad ground or wrong bulb installed can cause the voltage to feed back from a tail light or turn signal can cause the cruise to shut off.

And of course check the vacuum hoses too.
__________________
2003 GMC Envoy 5.3

Mr Car Guy is offline Mr Car Guy's Gallery  
Reply With Quote
Unread 07-10-2009, 03:38 PM   #4
New Member
 
Join Date: May 2009
Posts: 2
Rep: 10 flyboy is on a distinguished road
Default

Thanks guys for your replies. I have tried all the things you have said but to no avail I think it has to go in the shop.

flyboy is offline  
Reply With Quote
Unread 07-10-2009, 11:47 PM   #5
Banned
 
Join Date: Apr 2008
Posts: 741
Rep: 72 StreetRacingTechno will become famous soon enough
Default

Switch itself may be bad, and being an intermittent problem (if I understand you correctly) it would be a pain in the arse to track down. Might want to try and get a used switch, or check a more specific forum to the type of car you have to see if it is a unique problem or something common that people know how to fix

StreetRacingTechno is offline StreetRacingTechno's Gallery  
Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 09:55 PM.

Shogun Interactive Development Copyright 2015 Shogun Interactive Development. All rights reserved.