CarForum.net - Car Forums, Automotive News and Community
Home Gallery Register Calendar Members List

Go Back   CarForum.net - Car Forums, Automotive News and Community > General Car Discussion > General Automotive Discussion

Reply
LinkBack Thread Tools
Unread 10-02-2010, 02:34 AM   #1
Senior Member
 
xXxALLANxXx's Avatar
 
Join Date: Feb 2010
Location: Michigan
Posts: 150
Rep: 11 xXxALLANxXx is on a distinguished road
Default Windshield Wiper

Ok, so since I've had my truck I've been fighting to keep my blades from squeaking and wobbling, but have made no progress so far. So I replaced the blades and bought some Bosch blades, but they still squeak and wobble really bad. I tightened the wiper arms, etc but they still wobble and squeak.


I've tried so many things but I can't seem to get it and I'm just tried of messing with it. So any suggestions or ideas?
__________________
My current ride: 1998 Chevorlet Truck S10 P/U 2WD 4.3 SFI OHV 6cyl
Miles: ~140,000

Recently replaced;
Passenger side mirror
Wiper blade motor
Headunit w/ speakers
Water pump
Front brakes, rotors and calipers

xXxALLANxXx is offline  
Reply With Quote
Unread 10-02-2010, 09:23 AM   #2
Now accepting bribes.
 
lautinjr's Avatar
 
Join Date: Oct 2007
Location: Currently Las Vegas
Posts: 4,311
Rep: 193 lautinjr has a spectacular aura aboutlautinjr has a spectacular aura about
Default

Ya its a older truck IT could be A PROBLEM with the motor but I would polish the wind shield first. Buy a 3m head light restoring kit 19.99 and wet sand OT with a power drill and the 3000 grit pad then with the polishing compound. Should help get rid of imperfections.
__________________
Please help reduce our mini van population and wear condoms!

lautinjr is offline lautinjr's Gallery  
Reply With Quote
Unread 10-02-2010, 01:36 PM   #3
Senior Member
 
xXxALLANxXx's Avatar
 
Join Date: Feb 2010
Location: Michigan
Posts: 150
Rep: 11 xXxALLANxXx is on a distinguished road
Default

I replaced with windshield wiper motor, it's not even 5 months old yet. You think the wiper arms themselves could be the problem?
__________________
My current ride: 1998 Chevorlet Truck S10 P/U 2WD 4.3 SFI OHV 6cyl
Miles: ~140,000

Recently replaced;
Passenger side mirror
Wiper blade motor
Headunit w/ speakers
Water pump
Front brakes, rotors and calipers

xXxALLANxXx is offline  
Reply With Quote
Unread 10-02-2010, 03:07 PM   #4
Now accepting bribes.
 
lautinjr's Avatar
 
Join Date: Oct 2007
Location: Currently Las Vegas
Posts: 4,311
Rep: 193 lautinjr has a spectacular aura aboutlautinjr has a spectacular aura about
Default

Was it a rebuilt motor? Make sure It's seeing 12v at the motor ground and power. Probably the windshield has imperfections.
__________________
Please help reduce our mini van population and wear condoms!

lautinjr is offline lautinjr's Gallery  
Reply With Quote
Unread 10-02-2010, 03:19 PM   #5
Senior Member
 
xXxALLANxXx's Avatar
 
Join Date: Feb 2010
Location: Michigan
Posts: 150
Rep: 11 xXxALLANxXx is on a distinguished road
Default

Yeah, it's a rebuilt one. I'll have to see if I can find my voltage meter.

I'll post what I find out.
__________________
My current ride: 1998 Chevorlet Truck S10 P/U 2WD 4.3 SFI OHV 6cyl
Miles: ~140,000

Recently replaced;
Passenger side mirror
Wiper blade motor
Headunit w/ speakers
Water pump
Front brakes, rotors and calipers

xXxALLANxXx is offline  
Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 06:15 PM.

Shogun Interactive Development Copyright 2015 Shogun Interactive Development. All rights reserved.